Kubernetes 1.7 外部依赖关系介绍

持续集成构建使用了以下版本的外部依赖关系,但是以下内容只供用户参考,用户在决定使用哪些版本的etcd,dockerrkt之前请查阅相关的安装或升级指南。

• Docker 1.10.3,1.11.2,1.12.6版本已经过验证

• Docker 1.12.6版本已知问题

1、 overlay2驱动程序不完全支持

2、 未完全支持实时还原

3、 没有共享的pid Namespace支持

• Docker 1.11.2 版本已知问题

1、 Debian Jessie(#27885)上的Aufs存储驱动程序的内核崩溃,可以由节点问题检测器识别

2、 泄漏文件描述符(#275

3、 每个容器额外的内存消耗(#21737

• Docker 1.10.3包含了RedHat为已知问题提供的反向端口

• 对于Docker 1.13.X的问题,请参阅1.13.X问题表

• rkt版本1.23.0+

• “入门指南”中列出了rkt运行时的已知问题

• etcd版本3.0.17

• Go版本:1.8.3。 链接到公告

• Kubernetes只能用Go 1.8编译。 对其他所有版本的支持被删除。